Minimum requirements and compatibilies | famil.care

Manuals

Download the user manuals and follow the instructions to use the famil.care system at best.


Minimum system requirements

The famil.care apps work on both iOS and Android devices (Samsung, LG, Huawei, Sony, Asus, HTC, Motorola, Xiaomi, Pixel, ecc...). Verify in this page if your device satisfies the minimum requirements of compatibility.

Any doubts or questions?

Contact us!

info.uk@famil.care

Apple Devices

Devices:
iPhone 5s or newer
Operating system:
iOS 9.0 or newer
Internet connection:
3G, 4G, Wi-Fi
Other:
GPS module for geolocalization, Bluetooth, Mobile traffic services (call and SMS)

Android Devices

Operating System:
Android 4.4.4(Kitkat) o newer versions for famil.care and famil.care 2U for Senior app.
Android 5.1 (Lollipop) or latest versions for famil.care 2U App for Junior.
Internet connection:
3G, 4G, Wi-Fi
Other:
GPS module for internet connection, Bluetooth LE 4.2, Mobile traffic services (call and SMS)